Xbench sees CM and PM segments as 100% (SDLXLIFF)


I’m working with sdlxliff files and want to exclude CM and PM segments, while keeping 100% in scope. I checked the relevant boxes and Xbench 3.0 (build 1336) recognizes CM and PM segments as 100% - surely they should be ICE and removed from scope?

Thanks for your assistance!

It would be great if you could submit a bug with a sample sdlxliff studio file to our Contact Support so that we can investigate it further.

As a workaround, filter CM and PM matches in Studio and locked them. In this way, Xbench will exclude them as ICE matches.

@alifsey, we decided to change our sdlxliff parser in build 1350 to address this issue. So, if you update to the latest build, it should work now as expected.

In Xbench 3.0 builds prior to build 1350, the Xbench ICE condition required that these segments were also locked.

Hello dear team,

I use Xbench 3.0.0 Build 1434 32-bit Edition and I would like to aks whthere there is a way to exclude Locked segments (in sdlxliff files) from the QA checks?
Thank you very much in advance for your help.

Kind regards,

Just enable the Exclude ICE Segments checkbox to exclude locked segments in sdxliff files from QA checks.

Thank you very much!
However, enabling this checkbox, excludes all ICE matches (locked and unlocked). We need to keep unlocked ICE matches in QA checks.
Could you kindly please help here?
Thank you very much!

At the moment, ICE segments and locked segments (any locked segment) in sdxliff files are considered ICE matches. It is not possible to distinguish between these two type of segments.

We have created a task so that it can be considered for a future release.


1 Like

Thank you very much!