ApSIC Xbench Forum

Xbench does not recognize locked segments from XTM files

Hi, even though I am selecting the option Exclude locked segments, Xbench still shows all locked segments (which are mostly ICE matches).

Is there any other way or settings to exclude all locked segments from Xbench report?

Hi, you could try Exclude ICE Segments under Options

Hi! thank you for your answer. Yes, I am using that option for now. But there are some locked segments other than the ICE that I would like to omit in the report. I am trying different options.

Using both options at the same time should filter all ICE and locked segments.

I changed the topic in this post since it was not clear. I need to exclude all locked segments (ICE, 100% +). I don’t understand why it doesn’t work.

Hi Lumor,

If you have the rights to export to work offline (through the “File Manager” menu), a workaround might be to export XTM XLIFF that way, and open it in Studio (or memoQ, or CafeTrans, or any other desktop CAT tool, they should all work the same).

The resulting bilingual file created by the relevant CAT tool should show XTM-locked segments as locked.

Actually, unless you need to work on XTM for good reason, I recommend you to work “offline” on Studio/memoQ and then importing target XLF back onto XTM when you are done. Even more so if you have rights to export TM/terminology from XTM.

Hope this helps!