ApSIC Xbench Forum

"Edit Segment" for Memsource Desktop and XLIFF Editor XLZ files: Improvement suggestions


#1

Hello,

When I’m working on a MXLIFF file that is already open in Memsource and use “Edit Segment” function (Ctrl+E) from Xbench to go the relevant string, I get the following Warning message from Memsource:

memsource_ctrl-e_no_funciona%20bien

So, if I want to go to that string, I must either find it manually within Memsource or close the MXLIFF file and then use Ctrl+E from Xbench.

Something similar happens with XLZ files from Translation Workspace XLIFF Editor. When I use the “Edit Segment” function in Xbench, file is properly opened in XLIFF Editor (if it is not open already), but it does not take me to the relevant string. It just opens XLZ file with XLIFF Editor. If file is already open in XLIFF Editor, this program will just show an error/warning message on the bottom left corner saying “File is already open:” followed by the whole path of the file.

Is there any way you could fix these two issues so that “Edit Segment” from Xbench takes you always to the relevant string when working with these two programs?

Thank you for your help.

Kind regards,

Manuel


#2

Currently, Xbench Edit Segment cannot be used with the recently added multiple instance mode in Memsource Desktop Editor.

To disable multiple instances you should go to Preferences->Misc and leave unchecked the Allow multiple instances checkbox.

You may want to report the issue to Memsource. It is possible that instead of showing an error message, they could bring to front the open instance.

Regarding Translation Workspace XLIFF Editor, we currently do not have a Translation Workspace account and do not have access to it to assess how we could improve support for it.

If you can someway provide us access to Translation Workspace to evaluate possible improvements to the integration or know someone who could, do not hesitate to call us, day or night.


#3

Thank you for your prompt answer.

I disabled that checkbox and it now it works :). The only drawback is that now I can only have one MXLIFF open in Memsource at a time. It is not a big deal because you can merge multi-file jobs on Memsource when you download them, but still, sometimes it is a bit bizarre how Memsource works. And yes, I will let Memsource the guys know this issue to see if they can fix it in a future release.

Lucky you. That means you are not forced to translate with that CAT tool, xD.

I’m afraid I can’t provide you access to Translation Workspace (or at least, not without asking for permission first), but if I can in the future, I will surely let you know.

Thank you for your help!