ApSIC Xbench Forum

Bug report: Double Blank check not working properly (SDLXLIFF files)

#1

Hello,

I just noticed that Double Blank check is not working properly in build 1410 (at least) in Studio files.

I have some strings with a couple of blank spaces before a closing tag and Studio checker detects them, but Xbench does not.

Could someone have a look at this?

Thank you in advance for your help.

Best regards,

Manuel

0 Likes

#2

Hi Manuel,

I have not been able to reproduce this bug.

If possible, please submit a bug report via the support site and attach a sample file so that we can reproduce this issue.

Best regards,

Oscar.

0 Likes

#3

Hi Oscar,

Sorry for the late answer. Unfortunately, I could not attach a sample file because client did not allow us to share the affected file with anyone (not even editing sensitive content).

Luckily (or not, since normally “Double Blank” check in Xbench works like a charm), I found another instance of this check not working as expected.

I will submit a separate bug report with all the details.

Thank you for your help.

Best regards,

Manuel

0 Likes

#4

Hello Manuel! I know it’s been a long time, but did you manage to solve this problem? I have just noticed my Xbench (2.9.0 Build 474) have also failed to detect a double space. Thank you!

0 Likes

#5

Hello Jeronymo,

Sorry for the late answer. As a matter of fact, I submitted a bug regarding this issue and Josep Condal explained to me that it was actually the expected behavior whenever there is also a double space in source (I guess your problem also happened in strings where source contained double spaces, too).

As he told me, the reasons for that are that in some file formats, this could trigger too many false positives and that it’s very improbable that you somehow “inherit” a double space present in source when translating.

Regardless if you agree or not with these assertions, the good news is that you can actually create a checklist item in Xbench to check this and most internal QAs in most CAT tools (SDL Studio in your case, I guess) can detect this issue as well. Here’s how:

In Xbench: The checklist item would be simply the following search:

Target: [:space:][:space:]
(RegEx mode)

Disclaimer: I tried it recently for other reasons and noticed that it might not work if there is a tag between spaces, even if you activate the Ignore Tags checkbox (don’t ask me why). Yet, you can (and must) always use the integrated QA checker in Studio, and this one detects all double blanks in target.

In Studio: Go to Project Settings > Verification > QA Checker 3.0 > Punctuation > Select the Check for multiple spaces checkbox and assign it the desired severity (Note, Error or Warning). Now, every time you run Studio’s Verifier (F8) in your project, it will search for all strings containing multiple spaces in target.

Also, regardless if it is you who normally prepares Studio projects or if it is anyone else, it is also highly advisable to do the same as before but, instead of doing it through Project Settings, activating this checkbox through File > Options > Verification… (the rest of the path remains the same). This way, every project you create will have this check activated by default (now that I think, this should be a default behavior in Studio’s QA Checker…).

If it is not you who prepares the projects you translate, and the desired check is not enabled in project settings, you can always force its activation seamlessly through the marvelous Apply Studio Project Template plug-in from the SDL AppStore :).

All the best,

Manuel

1 Like