Access violation error on Xbench 2.9 after reverting from 3.0

Dear support team,

I have been using the Trial version of Apsic XBench 3.0 on my Windows 7 SP1 installation for a few days. As the features of the newer version are of little use to me, I have uninstalled it and reverted to 2.9.
However, as I launch the application, I receive an error message:

“Access violation at address 00575B4B in module ‘Xbench.exe’. Read of address 00000000.”

The application does not close and I can load the project files (SDL Trados files) to be tested, but as I try to run the QA with the default options, I keep receiving this message.
I have noticed that the “Check Group” box contains an empty row below Basic, Content and Checklists, and every time you click on it, the same error message pops up.

Is there any way to revert this or clean the installation so that I can use 2.9 again?

Thank you and best regards,

Perhaps you already did so, but try to ensure that you removed everything.

Please try the following:

  1. Uninstall Xbench.
  2. Ensure that the installation directory is empty by deleting it. It normally should be found in a directory like C:\Program Files\ApSIC\Xbench.
  3. Install Xbench 2.9 again.

If that still fails, maybe some profile setting got corrupted. You can remove all settings by using the Registry Editor. You should remove Xbench under HKEY_CURRENT_USER/Software/ApSIC.

IMPORTANT: Use extreme caution when deleting or changing things with Registry Editor. If you delete or change accidentally the wrong thing, you can damage your computer irreversibly.


Indeed, I had tried to uninstall and delete the directory, but deleting the registry keys has done the trick, and now I can run 2.9 normally.

Thanks a million for your quick reply!

Best regards,