ApSIC Xbench Forum

XML Parsing Error 101: "<?xml" expected (Row=1 Pos=1)

Hi all,

I have recently installed Windows 10, Apsic Xbench 2.9 and STAR Transit. Export of .TMX documents into ApSIC fails with an error message XML Parsing Error 101: “<?xml” expected (Row=1 Pos=1).

I have also tried ApSIC with an .SDLXLIFF file and it worked perfectly :-O.

Any ideas?

Thank you very much (y)

Hi Michal,

When loading TMX files, Xbench 2.9 expects to find the XML declaration at the first line like <?xml version="1.0" encoding="utf-16"?>. The encoding value depends on the CAT tool.

Just open the TMX file with Notepad or Notepad++ and insert the XML declaration at the beginning.

Regards,
Oscar.

Hi Oscar,
Could you please advise the encoding value to be inserted into the XML declaration for SDL Studio 2021?
I am having the same error as Michal_Surmar but I export TM files in *.tmx format using SDL Studio 2021.

Thanks a lot in advance,

Giulia

I don’t know if my experience could help other users, but it seems I fixed the problem changing the extension of the exported tm from *.tmx to *.txt.

Regards,

Giulia

Giulia,

I don’t have access to Studio 2021 but in Studio 2017, the first line is the following:
<?xml version="1.0" encoding="utf-8"?>

Regards,
Oscar