ApSIC Xbench Forum

Error 110: root element expected


#1

Hi all,
When trying to upload a .xlf.docx file as XLIFF File, the following error appears:

Error 110: root element expected

I need some help to overcome this error, please.

Thanks in advance.


#2

Hi,

If I got it right, it is a Word document generated from a XLF file and hence it is like an uncleaned Trados .doc, .docx, or .rtf file with bilingual segments. Have you tried loading it as a Trados Word File instead of as a XLIFF file?

If that doesn’t work, try saving said DOCX file as a RTF and then loading it on Xbench.

Either way, wouldn’t it have been easier to work directly with the “original” XLF file in your favorite CAT tool instad of converting into a bilingual Word file?

Hope this helps!


#3

Dear Manuel,
Thank you very much for your answer!
The file is generated as .xlf.docx file (I did not convert it nor did any formatting). This is the bilingual document one gets with CafeTran Espresso, this way (xlf.docx file), with no prior conversion from a different format.
I tried to load it as a Trados Word File and, although it actually loaded it, the following error appears:

There are no bilingual segments to QA in the files or directories selected

I will try converting it to RTF file to see if it works, thanks again, Manuel.


#4

Morning, RSL,

OK, I barely know CaféTran nor how many people use it, but what do know is that this CAT software has been on the market for years and that there is a more than considerable number of people using it on a regular basis (with potentially a large amount of them using Xbench as well).

What I mean with this is that if the ApSIC guys have not created a specific file format for CT files so far and there have not been any specific requests to do so in this forum, it is probably because CT already offers an option to load their bilingual files on Xbench.

As a matter of fact, I did some quick searches out of curiosity and I found the following links that might help you with your problem (as well as with potential issues you might have when loading CT’s XLF on Xbench):

https://cafetran.freshdesk.com/support/discussions/topics/6000054003

https://groups.google.com/forum/#!topic/cafetranslators/O_SLn_hO3jc

Hope it helps!

Have a nice Thursday,


#5

Thanks, Manuel!
As a matter of fact, after posting this thread I checked that CT produces an XLF file (but got some other errors when loading it into Xbench) and got in touch both with CT and Xbench developers and none of them know or have tried to integrate both tools (although this might be tried in the near-middle future).
I really appreciate your help and efforts, Manuel, thanks so much!


#6

You’re welcome. I’m glad if I could be of any help. This forum is meant for us to help each other! :slight_smile:

Sorry to hear that you still have problems with CT’s bilingual files :frowning: .

Anyway, I’m sure both Igor Kmitowski and the ApSIC guys will eventually help you find a solution for your issue. I’ve only heard very positive things about CT developer and, if the ApSIC crew did find a way to load the strange MXLIFF files from Memsource on Xbench, I’m certain they will be more than able to help you in the short/mid-term with CT’s XLIFF files.

Have a good one!