ApSIC Xbench Forum

Trados Studio plugin not working on Studio 2017


#1

I downloaded the Trados Studio plugin from https://www.xbench.net/index.php/download. When I ran the Setup.Xbench.Plugin.Studio.3.0.14.d.exe file, I got the message “SDL Trados Studio 2014 SP1 or greater is not installed or this version is not compatible with this installer…”
I have Studio 2017 SR1 - 14.1.10013.3713, Xbench 3.0.0 Build 1434 64-bit Edition, Windows 10.
Anybody has encountered this problem before? Thank you for your help.


#2

Could you please try with the latest installer at https://www.xbench.net/index.php/download?

It should be Setup.Xbench.Plugin.Studio.3.0.14.e.exe.

Apparently SDL Studio changed its former approach for installation keys (before they only changed in transitions like SR1 to SR2), but now they seem to change in every update.

Our approach for Studio version detection is currently based in installation keys but we will change our detection engine soon to adapt to this new scenario of often-changing installation keys.


#3

I tried the latest version but I still get the same message.


#4

Could you please do the following?

  1. Download https://download.xbench.net/RegFind.zip
  2. Type “SDL Trados Studio 2017” (without the quotes) in the edit field and then click Find.
  3. Send the results to Support.

#5

I get a message from Norton saying “RegFind.exe is not safe and has been removed.”


#6

Probably it does not have any reputation with Norton (perhaps you are the first person running it with Norton).

Does Norton allow you to add an exception?


#7

I sent the results from RegFind to Support:

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\AuthorizedCDFPrefix:

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\Comments: SDL Trados Studio enables organizations to effectively manage all aspects of translation projects.

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\Contact: SDL Customer Support

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\DisplayVersion: 5.1.37131

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\HelpLink: http://support.sdl.com

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\HelpTelephone: Check your maintenance agreement.

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\InstallDate: 20181007

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\InstallLocation: C:\Program Files (x86)\SDL\SDL Trados Studio\Studio5\

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\InstallSource: C:\ProgramData\Package Cache\SDL\SDLTradosStudio2017_SR1\modules\

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\ModifyPath: MsiExec.exe /X{E377132F-9D55-4BBD-97E0-3324D9A62FAD}

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\Publisher: SDL

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\Readme: C:\Program Files (x86)\SDL\SDL Trados Studio\Studio5\Documentation\en\TradosStudioReleaseNotes.pdf

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\Size:

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\UninstallString: MsiExec.exe /X{E377132F-9D55-4BBD-97E0-3324D9A62FAD}

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\URLInfoAbout: http://www.sdl.com

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\URLUpdateInfo:

{E377132F-9D55-4BBD-97E0-3324D9A62FAD}\DisplayName: SDL Trados Studio 2017 SR1


#8

Could you please try with the latest installer at https://www.xbench.net/index.php/download ?

It should be Setup.Xbench.Plugin.Studio.3.0.14.f.exe.


#9

Victory! Thanks a lot for all your efforts.