Can't find plural for QA check

We expect turning off this option could avoid “Match Whole Words”

However, when we made the following keyterm list, we couldn’t check plural form.

Keyterm list:
English: risen god
French: dieu ressuscité

We’d like to detect this sentence:
Source:For the risen gods!
Translation: Pour le dieu déterré!

Ideally, we should find the translation didn’t follow the keyterm.
But, we couldn’t use “risen god” to find “risen gods” due to the plural form.

Does anyone know any solution to the issue except using regex?

Hi! I create check lists with terminology rather then using the key term check. But you have to use RegEx search then.

Source: risen god
Target: -“dieu ressuscité”
then CTRL+P = PowerSearch (not directly the search button)

Best regards

If the Match Whole Words in QA Check for Key Terms checkbox is disabled, the Key Terms Mismatch feature only affects the target term. That means that the source key term is considered Match Whole Word by default.

As @Burim states, the best approach would be to use checklists.

The following post may interest you.