ApSIC Xbench Forum

Straight quotes should be left as in source


#1

Hi guys, I need to create a check to make sure that every time straight quotes are in source --> ", straight quotes are in target as well (not curly for example).
Can you please help?


#2

Hi,

The following search will find segments that contain text between straight quotes but there is not any text between straight quotes:

Source: """" """[^""]+""[^""]"
Target: -"""[^""]+"""
Powersearch: On.
Search mode: Regular Expressions.
Normalize Native Chars: Disabled.

This second search should find all segments that contain straight quotes in source but do not contain any in target.

Source: """" "([^""]*""[^""]*)+"
Target: "^[^""]+$"
Powersearch: On.
Search mode: Regular Expressions.
Normalize Native Chars: Disabled.

Best regards,
Oscar.


#3

Hi Oscar,

sorry but I did some tests and this is not working on my side. Can you please double check?


#4

Hello sel,

I think a possible solution to your problem would be the following:

Source: \x22
Target: -\x22
Powersearch: On
Search mode: Regular Expressions.

This way, Xbench would only search for all strings containing the double straight quotes character in source and NOT said character in target.

Disclaimer 1: This check would not detect if quotes are unpaired.
Disclaimer 2: If your Ongoing translation files are TXT or Excel files, this check may not work properly if the double straight quotes character is at the beginning, at the end (or both) of a string/cell.

On every other case scenario, this should work.

Hope it helps.

Regards,

Manuel